Не передаются комментарии к ордерам в Quik
Atom Ответить
04.03.2015


Всем доброго дня!
Подскажите, может кто-то сталкивался с подобной проблемой...
При отправке ордера в Quik упорно не хочет передаваться комментарий к нему. Комментарий добавляю через order.Comment. Смотрю лог, а параметр Comment просто не передается в Quik... что я делаю не так ?

Теги:


Спасибо:




5 Ответов
ilmir

Фотография
Дата: 30.06.2015
Ответить


askretov Go to
Всем доброго дня!
Подскажите, может кто-то сталкивался с подобной проблемой...
При отправке ордера в Quik упорно не хочет передаваться комментарий к нему. Комментарий добавляю через order.Comment. Смотрю лог, а параметр Comment просто не передается в Quik... что я делаю не так ?



В Quik DDe нормально все комментарии идут , а вот Quik Lua работает без комментариев у меня , а вы какой коннектор используете?
Спасибо:

Mikhail Sukhov

Фотография
Дата: 01.07.2015
Ответить


ilmir Go to
В Quik DDe нормально все комментарии идут , а вот Quik Lua работает без комментариев у меня , а вы какой коннектор используете?


Попробуйте последние коммиты на гите.
Спасибо:

ilmir

Фотография
Дата: 08.07.2015
Ответить


Mikhail Sukhov Go to
ilmir Go to
В Quik DDe нормально все комментарии идут , а вот Quik Lua работает без комментариев у меня , а вы какой коннектор используете?


Попробуйте последние коммиты на гите.


Там есть проблемка по сборке Lua с гиты , https://stocksharp.ru/fo...ka-konniektora-QuikLua/ опубликован список *.dll которые необходимы для работы Lua , но которых нет на гите , у меня не получалось раннее собирать с гиты Lua , получалось DDE и др. , и ошибку распознать так же не получалось так как , при запуске Lua в квике Quik просто пишет ошибка запуска скрипта и все на этом , было бы хорошо если сделали видеоролик как совмещать гиту с текущей версией библиотеки , как с гиты Lua запускать .

Спасибо:

Mikhail Sukhov

Фотография
Дата: 08.07.2015
Ответить


В видео смысла нет. Если нет опыта с собиранием версии из исходников, то подождите релиза.
Спасибо:

RomSunZ

Фотография
Дата: 13.07.2015
Ответить


ilmir Go to
Mikhail Sukhov Go to
ilmir Go to
В Quik DDe нормально все комментарии идут , а вот Quik Lua работает без комментариев у меня , а вы какой коннектор используете?


Попробуйте последние коммиты на гите.


Там есть проблемка по сборке Lua с гиты , https://stocksharp.ru/fo...ka-konniektora-QuikLua/ опубликован список *.dll которые необходимы для работы Lua , но которых нет на гите , у меня не получалось раннее собирать с гиты Lua , получалось DDE и др. , и ошибку распознать так же не получалось так как , при запуске Lua в квике Quik просто пишет ошибка запуска скрипта и все на этом , было бы хорошо если сделали видеоролик как совмещать гиту с текущей версией библиотеки , как с гиты Lua запускать .



Компилируете свой проект, в который подключаете нужные библиотеки с гита (квик коннектор, xaml и т.п.). После компиляции идете в папку с гит, открываете папку с коннектором (GitHub)\Connectors\Quik\bin, идете в debug или release (смотря что вы компилировали), и от туда копируете все библиотеки dll в папку с вашим скриптом StockSharp.Quik.lua, который подключатете в терминале квик. Не забудьте из папки (GitHub)\References скопировать также StockSharp.Licensing.dll
Спасибо:


Добавить файлы через драг-н-дроп, , или вставить из буфера обмена.

loading
clippy