Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx)
Atom
09.10.2012




Вылетает при старте экспорта.. жалуется на вот эту строку:
Код
				retVal.AddRange(str.Split(new[] { ',' }, StringSplitOptions.RemoveEmptyEntries).Select(s => s.To<Guid>()));

Теги:


Спасибо:




1 2  >
StockSharp

Фотография
Дата: 09.10.2012
Ответить


нужно старую БД сносить. На новой версии БД другая
Спасибо:

XMbIPb

Фотография
Дата: 10.10.2012
Ответить


Если снести базу, то экспорт стартует нормально только один раз.. а со второго опять начинает вылетать эта хрень...
Спасибо:

Moadip

Фотография
Дата: 10.10.2012
Ответить


Подскажите номер сборки, чтобы можно было воспроизвести ошибку.
Спасибо:

XMbIPb

Фотография
Дата: 10.10.2012
Ответить


19868
Спасибо:

Moadip

Фотография
Дата: 10.10.2012
Ответить


Сборка 19868 появилась только сегодня. На ней тоже ошибка появляется?
Спасибо:

XMbIPb

Фотография
Дата: 10.10.2012
Ответить


да.. и в 19869 тоже...
Спасибо:

Mikhail Sukhov

Фотография
Дата: 10.10.2012
Ответить


XMbIPb Перейти
да.. и в 19869 тоже...


Просто если использовать Квик, то ошибка не воспроизводится. Вы видимо что-то еще делаете в Гидре, кроме как включение Квик источника и нажатия на кнопку Старт.
Спасибо:

XMbIPb

Фотография
Дата: 10.10.2012
Ответить


Хотя нет.. в 19869 вроде пропала.. я просто базу для неё забыл снести.. перезапустил несколько раз.. вроде пока чисто стартует...
Спасибо:

XMbIPb

Фотография
Дата: 10.10.2012
Ответить


В 19868 я сносил базу, включал квик, обновлял инструменты, нажимал старт, останавливал и снова жал старт.. но второй раз экспорт уже не стартовал... между 19868 и 19869 ничего не делал.. только базу по новой снёс...
Спасибо:

XMbIPb

Фотография
Дата: 11.10.2012
Ответить


Ошибка снова появилась после очередного перезапуска экспорта.. но теперь она хотя бы пытается его запустить.. примерно каждые 20 секунд появляется окошко вывода через дде сервер.. при каждом появлении снова вылетает эта ошибка.. иногда раза с десятого экспорт всё-таки стартует..
У Вас воспроизвести не получается наверно потому, что брокер(у меня финам) или ось(у меня вин сервер 2012) отличаются..
Я так понимаю ей не нравится какое-то значение в ExtensionInfo какого-то инструмента.. это может быть как-то связанно с языковыми настройками или форматом времени/даты? а то у меня до этого гидре не нравился формат времени(винда английская)
Посоветуйте куда копать.. может сам разберусь...
Спасибо:
1 2  >

Добавить файлы через драг-н-дроп, , или вставить из буфера обмена.

loading
clippy