Не работает Quik Lua с версией Quik 8.13.1.16
Atom
30.06.2021


С версией 8.13.0 все работает, на 8.13.1 в lua 5.3 не запускается - просто ошибка скрипта, в логе пусто. При запуске в 5.4 в StockSharp.QuikLua.FatalError.log
[30.06.2021 09:42:46] Ошибка инициализации: System.ArgumentException: Error load procedure lua_tolstring.
Parameter name: procName ---> System.ComponentModel.Win32Exception: The specified procedure could not be found
--- End of inner exception stack trace ---
at Ecng.Interop.Marshaler.GetProcAddress(IntPtr hModule, String procName)
at #=z6LDbkiB_o39SOZfN$_pI_DOE3eYK..ctor(String #=zmYbYGNI=)
at #=zPdhCudmWZB75RGlDByDiqkMGJ2g5..ctor(String #=zmYbYGNI=, IntPtr #=z2sHMsJEwY6Qw)
at StockSharp.QuikLua.QuikDll.#=zrEyvRD4=(String #=zmYbYGNI=, IntPtr #=z2sHMsJEwY6Qw)

Теги:


Спасибо:


titan

Фотография
Дата: 30.06.2021
Ответить


А на чем проверяли, если не секрет. На примере Стокшарпа или собственный бот участвовал?
Спасибо:

Balex

Фотография
Дата: 30.06.2021
Ответить


Цитата:
А на чем проверяли, если не секрет. На примере Стокшарпа или собственный бот учавствовал?

Я про Lua компонент в Quik, проблема с его запуском в принципе
Спасибо:

titan

Фотография
Дата: 30.06.2021
Ответить


Немного подробностей эксперимента больше хотелось...Откуда Stocksharp.Quik.lua взяли?
Спасибо:

Balex

Фотография
Дата: 30.06.2021
Ответить


Текущая версия из Installer'а
Спасибо:

Balex

Фотография
Дата: 30.06.2021
Ответить


Ошибся в проблеме. Не работает именно последняя версия компонента, старая от декабря 2020 работает в lua 5.3 на этой же версии quik
Спасибо:

Юрий Басангов

Фотография
Дата: 30.06.2021
Ответить


Balex Перейти
Ошибся в проблеме. Не работает именно последняя версия компонента, старая от декабря 2020 работает в lua 5.3 на этой же версии quik


При корректной установке проблем не замечено.
Версия Quik 8.13.3.1
Версия Lua 5.3.5



Рекомендую полностью переустановить коннектор к Квику.
image7565.png 42 KB (234)
Спасибо:

Balex

Фотография
Дата: 30.06.2021
Ответить


Все с нуля (Quik 8.13.1.16 от Открытия), StockSharp.Quik.dll в версии 5.0.0.0 и все компненты вчера вытащинные инстолером. Все так же не работает.
Попробовал на Quik 8.7 от Сбера - тот вообще падает при запуске lua скрипта

Версия от декабря 2020 работает в обоих quik.

Не подскажете, как можно дальше исследовать проблему?
Спасибо:

Balex

Фотография
Дата: 30.06.2021
Ответить


Еще раз все снес, поставил с нуля... и о чудо, работает. Извините за беспокойство и спасибо за помощь
Спасибо:


Добавить файлы через драг-н-дроп, , или вставить из буфера обмена.

loading
clippy