Ошибка запуска скрипта (StockSharp.Quik.lua) в терминале quik на Windows Server 2008 r2


Ошибка запуска скрипта (StockSharp.Quik.lua) в терминале quik на Windows Server 2008 r2
Atom Ответить
06.06.2017


Здравствуйте. При попытке запустить скрипт (StockSharp.Quik.lua) в Quikе выбрасывает ошибку:
Цитата:

error loading module 'StockSharp' from file 'C:\....путь...\StockSharp.QuikLua.dll':
Не найден указанный модуль.

Quik работает на Windows Server 2008 r2. Библиотека StockSharp.QuikLua.dll по указанной директории присутствует. В чем может быть проблема?



Спасибо:




28 Ответов
< 1 2 
Support

Фотография
Дата: 26.06.2017
Ответить


..
Спасибо:

RomSunZ

Фотография
Программист
Дата: 04.07.2017
Ответить


Подскажите, почему в крайней версии 4.3.25 QuikLua не передает статус по инструментам?
Лог из StockSharp.QuikLua.log:
Цитата:

2017/07/04 20:56:01.378|Debug |LuaServer |Out. Level1Change,T(L)=0001.01.01 00:00:00.000,T(S)=2017.07.04 20:56:01.448,Sec=S#:SRU7@FORTS, Native:,Type:,Changes=[PriceStep, 1],[StepPrice, 1],[BestBidPrice, 15237],[BestBidVolume, 16],[BestAskPrice, 15246],[BestAskVolume, 2],[BidsCount, 169],[AsksCount, 127],[BidsVolume, 4711],[AsksVolume, 1545],[LowPrice, 15200],[HighPrice, 15254],[ClosePrice, 15240],[LastTradePrice, 15240],[LastTradeVolume, 10],[VWAP, 15227],[TradesCount, 725],[SettlementPrice, 15240],[Volume, 1923],[MinPrice, 14173],[MaxPrice, 16307],[MarginBuy, 2134],[MarginSell, 2134],[OpenInterest, 26188],[State, Stoped]
2017/07/04 20:56:01.378|Debug |FixServer |To client quik (127.0.0.1:6252): 8=FIX.4.4^9=324^35=W^49=quik^56=StockSharpMD^52=20170704-13:56:01.449^34=13293^55=SRU7^207=FORTS^262=73856288^268=5^269=b^270=15237^272=20170704^273=13:56:01.448^269=n^271=16^272=20170704^273=13:56:01.448^269=q^271=169^272=20170704^273=13:56:01.448^269=w^271=4711^272=20170704^273=13:56:01.448^269=6^270=15240^272=20170704^273=13:56:01.448^10=027^

При этом в терминале в таблице инструментов стоит статус "торгуется".
Спасибо:

Пахан

Фотография
Дата: 18.03.2020
Ответить


есть ли в природе StockSharp.QuikLua.dll для х64?

работаю в visual studio 2019 x64. квик так же x32
x86 устанавливать нет возможности.
Спасибо:
< 1 2 

Добавить файлы через драг-н-дроп, , или вставить из буфера обмена.

loading
clippy