Quik и ошибка отмены стоп-ордера
Atom Ответить
29.03.2016


Добрый день!

Столкнулся с такой проблемой, лог прилагаю: https://gyazo.com/8db6c70fbb71ccf7d6b4b34c3aafcce5

Выставленная через API лимитная заявка имеет статус Pending (на QUIKJunior сервере стоп заявки были со статусом Active) и на попытку отмены реагирует как указано в логе (не было корректно обработано...).
Если попытки отмены заявки были ранее, то пишет "для заявки уже подан сигнал на отмену".

Снять заявку через API никак не получилось.



Теги:


Спасибо:




31 Ответов
1 2  >
kiaveryanov

Фотография
Дата: 29.03.2016
Ответить


UPD:

В Samples точно такая-же такая-же беда. Установленные заявки не отменяются, в окне отображения стоп-заявок висят со статусом "регистрируется".
Возможно это из-за каких-то изменений у Открытия в статусе заявок, что весьма печально =(
Автор топика
Спасибо:

kiaveryanov

Фотография
Дата: 29.03.2016
Ответить


UPD:

Действительно проблема только у Quik от брокера "Открытие". Состояние стоп-заявок не меняется после регистрации, так и остается "Pending"...
Автор топика
Спасибо: Slepoy

kiaveryanov

Фотография
Дата: 30.03.2016
Ответить


Покопался в исходниках крайней версии, добрался до FixServer, дальше никак =(

Накопал лог QuikSample:

Код
2016/03/30 16:46:12.718|       |QuikTrader|CancelOrder: 60042433/ Продажа Цена=68500 Объем=1 Сост=Pending Бал=1 
2016/03/30 16:47:10.745|Debug  |Quik LUA. Transactions|Сессия '127.0.0.1:5001 Sender quik Target StockSharpTS'. Получено: '8=FIX.4.0^9=71^35=3^49=quik^56=StockSharpTS^52=20160330-13:47:10.749^34=59^45=0^372=F^10=109^'
2016/03/30 16:47:10.744|Debug  |QuikTrader|BP:Error,T(L)=2016.03.30 16:47:10.745,Error=Сообщение 0 типа F не было корректно обработано FIX сервером. Причина () .
2016/03/30 16:47:10.745|Error  |QuikTrader|System.InvalidOperationException: Сообщение 0 типа F не было корректно обработано FIX сервером. Причина () .
2016/03/30 16:47:16.970|Debug  |Quik LUA. Transactions|To server: 8=FIX.4.4^9=176^35=F^49=quik^56=StockSharpTS^52=20160330-13:47:10.749^34=18^1=4100XWX^41=60042433^11=60042450^55=SiM6^207=FORTS^461=FFXXXX^167=FUT^54=2^60=20160330-13:46:35.713^58=Conditional^10=014^
2016/03/30 16:48:57.944|Debug  |Quik LUA. Transactions|Сессия '127.0.0.1:5001 Sender quik Target StockSharpTS'. Получено: '8=FIX.4.0^9=73^35=0^49=quik^56=StockSharpTS^52=20160330-13:48:57.950^34=60^112=60042452^10=220^'



Я понимаю, что техподдержка "левых" разработчиков дело безперспективное, но это все-же проблема взаимодействия с брокером.
Планируется ли что-либо с этой проблемой делать, или все останется как есть?
Автор топика
Спасибо: Slepoy

Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 30.03.2016
Ответить


kiaveryanov Перейти
проблема взаимодействия с брокером.


Брокер Открытие - очень странный брокер. Они вначале с нами инициировали сотрудничество, затем прекратили. Поддерживать их редакцию Квика, конечно же, мы не можем в такой ситуции. Как вариант - под роботов используйте другого брокера.
Спасибо:

Slepoy

Фотография
Дата: 30.03.2016
Ответить


Mikhail Sukhov Перейти
kiaveryanov Перейти
проблема взаимодействия с брокером.

Брокер Открытие - очень странный брокер. Они вначале с нами инициировали сотрудничество, затем прекратили. Поддерживать их редакцию Квика, конечно же, мы не можем в такой ситуции. Как вариант - под роботов используйте другого брокера.



Брокер может и странный, но он один из самых крупных на нашем рынке. Чего не скажешь о мелочи типа АйтиИнвест. Вот АйтиИнвест - вот это вот действительно странный брокер ))). Мало того, что он мелкий, так у него ещё и глючный собственный интерфейс СмартКом. Данный интерфейс за глюки ругают все кому не лень. Тем не менее, вы сделали для него свой коннектор. Так почему для Открывашки, не запилить в каком-либо классе, либо коннекторе, ответвление для отработки данной ошибки? Нельзя же так просто взять и отмахнуться от тысяч клиентов. Вот брокера АйтиИнвест - выпилить можно ))) т.к. он мелкий и глючный, но Открывашка - это совсем другое дело, это другие масштабы. Ну вы сами прикиньте расклады: кому будет охота менять своего проверенного надёжного брокера ради API Стокшарпа? У меня не раз спрашивали совета, о том на чём писать роботов - я всегда советовал стокшарп. А что я теперь буду советовать? Что я должен теперь им ответить? Меняйте брокера, но не радуйтесь, ибо если завтра БКС намутит в своём Квике какую-либо хрень, то никто API стокшарпа допиливать ради БКС не будет. Ради Открывашки не стали, и ради БКС не будут, а потом и ради Финама тоже. Фактически данным заявлением об отказе допилить API под Открывашку, вы создаёте опасный прецедент. Прецедент, который говорит всем, что рано или поздно такое же может постигнуть и остальных брокеров если они чего-то намутят в своих Квиках, и пользователей в будущем ждёт облом по всем фронтам. Вы фактически сейчас данным заявлением напугаете всех потенциальных клиентов. Нельзя так поступать. Клиенты должны видеть будущее и перспективы. А после данного заявления, никакого будущего и в помине не видать. Плохо будет всем: и вам и нам. Мне тут в личку недавно писали, предлагали сотрудничеству развития паралленого проекта open source, фактически вашего конкурента. Я конечно отказался, т.к. как программист я полный ноль ))), но сам факт вас должен настораживать. Если завтра всё трейдерское сообщество узнает, что перепективы стокшарпа туманны и ведут в тупик. Узнает, что некоторые крупные брокеры уже не поддерживаются, и что не факт что текущие брокеры будут поддерживаться в будущем, то о каком будущем стокшарпа можно говорить? Слухи распространются очень быстро, и ваши конкруренты на этом сделают себе имя! Мол не ходите к ним, идите к нам - у нас всё хорошо, и все брокеры поддерживаются. Подумайте ещё раз над всем этим. Взвесьте все за и против. Подумайте о возможных неблагоприятных последствиях для всех сторон. Пока еще не поздно, пока ещё можно всё поправить и изменить решение.
Спасибо:

Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 30.03.2016
Ответить


Slepoy Перейти
Mikhail Sukhov Перейти
kiaveryanov Перейти
проблема взаимодействия с брокером.

Брокер Открытие - очень странный брокер. Они вначале с нами инициировали сотрудничество, затем прекратили. Поддерживать их редакцию Квика, конечно же, мы не можем в такой ситуции. Как вариант - под роботов используйте другого брокера.



Брокер может и странный, но он один из самых крупных на нашем рынке.


Только не в алготрейдинге. И да, Финам и БКС поддерживаем.

Мы не отказываемся от сотрудничества с Опеном. Это они не заинтересованы в направлении алготрейдинга, и их месседж был недвусмысленный. Насильно мил не будешь.

Менять брокера я не предлагал. Можно под роботов открыть счет у другого брокера. Можно не использовать те вещи к Квик, что были изменениы Опеном и несовместимы с основной версией.

Насчет СмартКом информация неверная. Их соединение, по нашим тестам, как раз одно из наиболее стабильных на рынке.
Спасибо:

Иван З.

Фотография
Курсы Автор статей Благотворитель
Дата: 31.03.2016
Ответить


У меня 2 брокера. Один из них Открытие. Quik от Открытия 6.17 у второго 7.0.4.
Так вот, мне как то ленно было перенастраивать Quik Открытия, я просто скопировал Quik второго брокера, и поменял ключи. Оказалось у открывашки работает Quik 7.0.4 без проблем. Заявки, стоп заявки отправлялись и тд.
Это я к тому что, если проблема именно в Quik то это может быть решение. Взять чисты Quik от производителя нужной вам версии.
Сам через Открытие алго не пробовал не для этих целей счет.
Спасибо: Slepoy kiaveryanov Mikhail Sukhov

Slepoy

Фотография
Дата: 31.03.2016
Ответить


Mikhail Sukhov Перейти
Только не в алготрейдинге


Всё равно, рано или поздно всё упрётся в кол-во клиентов ))). АйтиИнвест исходно затачивались под алготрейдинг, а Открывашка в это время тупила.
Судя по сайту, Открывашка проталкивает Кофите и ТСлаб. Ну и глючный MetaTrader 5. Рано или поздно они догонят и перегонят АйтиИнвест... возможно )))


Mikhail Sukhov Перейти
Это они не заинтересованы в направлении алготрейдинга, и их месседж был недвусмысленный

Судя по их сайту они как раз заинтерисованы в направлении алготрейдинга. Скорей всего именно из-за сложности API стокшарпа, они и откзались сотрудничать. Они расчитывают на среднестатистического россиянина, который не особо хочет парится в программировании, он хочет готовый продукт типа ТСлаба. Вам надо Открывашке показать свой Дизайнер(студию) с кубиками, может Открывашка и передумает.


Mikhail Sukhov Перейти
Менять брокера я не предлагал. Можно под роботов открыть счет у другого брокера.

Это фактически одно и тоже. Зачем алготрейдеру торговать вручную? Мне лично лень торговать вручную ))). Пусть роботы батрачат на всех счетах.


Mikhail Sukhov Перейти
Можно не использовать те вещи к Квик, что были изменениы Опеном и несовместимы с основной версией.

Сегодня, я впервый попробовал отправить пару реальных заявок через свой полу-привод написанный с помощью API стокшарпа. До этого, я данный недо-привод испытывал только на демке. В общем, обычные заявки отправляютно номально. На счёт стоп-заявок я не проверял, я ещё не умею ))). Может действительно это глюк конкретной версии Квика Открывашки, я на это очень надеюсь. Мне нисколько не хочется менять брокера, причём публичные тарифы у Открывашки - самые низкие на рынке.

http://i11.pixs.ru/thumbs/3/2/2/HitmanSkal_7251653_21344322.jpg


Mikhail Sukhov Перейти
Насчет СмартКом информация неверная. Их соединение, по нашим тестам, как раз одно из наиболее стабильных на рынке.

Стабильное на каком промежутке времени? На смартлабе я встречал достаточное кол-во постов, как из-за смарткома люди плакали. А что такое смартком? Это внутренний протокол позволяющий подсоединяться к серверам АйтиИнвеста, которые постоянно глючат. Любой глюк сервера АйтиИнвеста отразится и на смарткоме. А кто у нас самый нестабильный брокер? Ну конечно же АйтиИнвест ))). АйтиИнвест давно уже подмочил свою репутацию и полностью себя дискредитировал. Да, безусловно, у смарткома хорошая скорость. На этом преимущества и заканчиваются ))). Далеко ходить не надо, ибо ваши же преподаватели, не буду называть имена чтобы не подставлять людей, сами упоминали про нестабильность смарткома и рекомендовали именно Квик, правда это было пару-тройку лет назад. Но судя по глюкам самого брокера АйтиИнвест - ничего не изменилось. Если и работать через АйтиИнвест, то только в обход его внутренней архитектуры, т.е. через Плаза 2, либо через новый протокол TWIME. Последний прикол про АйтиИнвест был на недавней конференции, на которой ваша компания представляла Дизайнер. И как раз видос, про то как парни теряли бабло в связке Тслаб+Смартком 2.2 - это просто шедевр ))). Я так давно не смеялся ))). Интересно, Твардовский в тот момент сильно покраснел от стыда? ))) Он же тогда руководил АйтиИнвестом.
Спасибо:

Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 31.03.2016
Ответить


Комментарий был от Опена касательно алготрейдинга. Именно вообщем их не интересует это направление. А линейка продуктов, что вы привели, у них висит уже лет 5 если не больше. Без каких либо обновление. Кофите так вообще успел загнуться, а все продолжает висеть на сайте брокера. Причина - не до этих алготрейдерских программ.

Slepoy Перейти

Стабильное на каком промежутке времени? На смартлабе я встречал достаточное кол-во постов, как из-за смарткома люди плакали. А что такое смартком? Это внутренний протокол позволяющий подсоединяться к серверам АйтиИнвеста, которые постоянно глючат. Любой глюк сервера АйтиИнвеста отразится и на смарткоме. А кто у нас самый нестабильный брокер? Ну конечно же АйтиИнвест ))). АйтиИнвест давно уже подмочил свою репутацию и полностью себя дискредитировал. Да, безусловно, у смарткома хорошая скорость. На этом преимущества и заканчиваются ))). Далеко ходить не надо, ибо ваши же преподаватели, не буду называть имена чтобы не подставлять людей, сами упоминали про нестабильность смарткома и рекомендовали именно Квик, правда это было пару-тройку лет назад. Но судя по глюкам самого брокера АйтиИнвест - ничего не изменилось. Если и работать через АйтиИнвест, то только в обход его внутренней архитектуры, т.е. через Плаза 2, либо через новый протокол TWIME. Последний прикол про АйтиИнвест был на недавней конференции, на которой ваша компания представляла Дизайнер. И как раз видос, про то как парни теряли бабло в связке Тслаб+Смартком 2.2 - это просто шедевр ))). Я так давно не смеялся ))). Интересно, Твардовский в тот момент сильно покраснел от стыда? ))) Он же тогда руководил АйтиИнвестом.


Правильно, потому что ТС лаб использует устаревший СмартКом 2. А мы используем 3. Это небо и земля по качеству. Да и сервера у всех единые. Если бы глючил сервер, каждый день бы кто-то писал негативное. А так у них failover сопоставимо с биржевым. Вот как раз про открытие я читал значительно чаще сообщений, чем про айти. На том же смарт лаб. И человек в видео говорит вовсе не про айти, а про тс лаб.
Спасибо:

Slepoy

Фотография
Дата: 31.03.2016
Ответить


Mikhail Sukhov Перейти
Комментарий был от Опена касательно алготрейдинга. Именно вообщем их не интересует это направление. А линейка продуктов, что вы привели, у них висит уже лет 5 если не больше. Без каких либо обновление. Кофите так вообще успел загнуться, а все продолжает висеть на сайте брокера. Причина - не до этих алготрейдерских программ.


Ну вроде сайт Кофите ещё робит. Правда уже больше года прошло с последнего обновления от 26.01.2015. Кстати, они же там в одном из интервью, вроде на сходке смартлаба, говорили что в их проект какой-то фонд дофига бабла вложил. Они на эти бабки контору свою и содержали. Видать ставка не сыграла ))).


Mikhail Sukhov Перейти
Правильно, потому что ТС лаб использует устаревший СмартКом 2. А мы используем 3. Это небо и земля по качеству. Да и сервера у всех единые. Если бы глючил сервер, каждый день бы кто-то писал негативное. А так у них failover сопоставимо с биржевым. Вот как раз про открытие я читал значительно чаще сообщений, чем про айти. На том же смарт лаб. И человек в видео говорит вовсе не про айти, а про тс лаб.

Ну все брокера падают, я не особо защищаю в этом плане Открывашку. Но АйтиИнвест выделяется из этого фона, причём в нелучшую сторону. Т.Мартынов переодически выкладывает на смартлабик ошибки их Матрикса, и матерится ))). Тут же появляется Вася Олейник и защищает брокера ))). У меня всегда при это поднимается настроение ))). На счёт видео. Я просто привёл свежий пример, где айти в очередной раз публично выделился. ТСлаб ведь в связке с плазой номально вроде робит, а вот в связке с смарткомом - глючит. Явно был виноват смартком. Да, он был старым. Может сейчас в версии 3 всё и поправили. Но где-то я видел пост на смартлабе, что и версию 3 нещадно били плетью, сравнивая её с версией 2.2: мол ожидали от 3й версии чуда и недождались. Правда тоже это было около года назад, может сейчас всё и допилили уже. Да, и тот же Морошкин(автор КьюСкальпа), то же как-то говорил на тему стабильности. Квик он называл самой стабильной штукой, мол он хоть и медленный, но стабильный на фоне других. НА смарталабе, как-то и траназак пинали тоже. В общем, пинают всех. Наша задача: выбрать того, кого пинают меньше ))). Я лично агитирую за Квик.
Спасибо:

Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 31.03.2016
Ответить


Slepoy Перейти

Ну все брокера падают, я не особо защищаю в этом плане Открывашку. Но АйтиИнвест выделяется из этого фона, причём в нелучшую сторону. Т.Мартынов переодически выкладывает на смартлабик ошибки их Матрикса, и матерится ))). Тут же появляется Вася Олейник и защищает брокера ))). У меня всегда при это поднимается настроение ))). На счёт видео. Я просто привёл свежий пример, где айти в очередной раз публично выделился. ТСлаб ведь в связке с плазой номально вроде робит, а вот в связке с смарткомом - глючит. Явно был виноват смартком. Да, он был старым. Может сейчас в версии 3 всё и поправили. Но где-то я видел пост на смартлабе, что и версию 3 нещадно били плетью, сравнивая её с версией 2.2: мол ожидали от 3й версии чуда и недождались. Правда тоже это было около года назад, может сейчас всё и допилили уже. Да, и тот же Морошкин(автор КьюСкальпа), то же как-то говорил на тему стабильности. Квик он называл самой стабильной штукой, мол он хоть и медленный, но стабильный на фоне других. НА смарталабе, как-то и траназак пинали тоже. В общем, пинают всех. Наша задача: выбрать того, кого пинают меньше ))). Я лично агитирую за Квик.


Даже владельцы сайтов предпочитают АйТи вместо Опена. Это же явно о чем-то говорит.

На видео четко сказано - проблема в ТС лабе. Потому что у нас СмартКом работает нормально. Мы сами его используем.
Спасибо:

Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 31.03.2016
Ответить


И подытожу (далее эту тему уже неинтересно развивать). С Опеном можем начать работать хоть сейчас. Проблема не с нашей стороны. Это их клиенты из алготрейдеров (тоесть вы) не интересуют. Но алготрейдеры - это наша клиентура. Их интересует видимо инвесторы и дей трейдеры. Пока мы не нашли точки соприкосновения с Опеном. У нас нет продуктов и планов в этом направлении. Решение я уже написал. Да и другие написали так же решение. Не вижу что еще можно обсудить.
Спасибо:

kiaveryanov

Фотография
Дата: 31.03.2016
Ответить


Mikhail Sukhov Перейти
И подытожу (далее эту тему уже неинтересно развивать). С Опеном можем начать работать хоть сейчас. Проблема не с нашей стороны. Это их клиенты из алготрейдеров (тоесть вы) не интересуют. Но алготрейдеры - это наша клиентура. Их интересует видимо инвесторы и дей трейдеры. Пока мы не нашли точки соприкосновения с Опеном. У нас нет продуктов и планов в этом направлении. Решение я уже написал. Да и другие написали так же решение. Не вижу что еще можно обсудить.


Решил проблему установкой крайней версии Quik и настройкой ее на работу с серверам Открытия. Благодарю Ивана за подсказку, стыдно, что сам не додумался =)
Автор топика
Спасибо:

Slepoy

Фотография
Дата: 31.03.2016
Ответить


kiaveryanov Перейти
Решил проблему установкой крайней версии Quik и настройкой ее на работу с серверам Открытия. Благодарю Ивана за подсказку, стыдно, что сам не додумался =)


Я бы пока не особо радовался. Иван, конечно предложил хороший вариант, я так же делал с демкой Финама и демкой от Арки. Но Иван, тестил новый терминал со старым сервером. Он клиетский терминал 7й версии подконектил к серверу Квика версии 6.17. Это так-то опасно. У Открывашки серверная часть Квика старая, ей как минимум нужно подсунуть клиентский Квик версии 6,17 и ниже, но никак не выше. АРКА 7ю версию конкретно перелопатили, и то что всё на первый взгляд работает - меня сильно удивляет, и может запросто в какой-то части все отвалится. Лучше с сайта АРКИ не качать последню версию Квика 7.1, а скачать именно старую 6.17.
Спасибо:

Maniac

Фотография
Дата: 01.04.2016
Ответить


Slepoy, раз Quik 7.x.x завелся, значит и 7.1.2 заведется. И сервера Октрытие обновили, иначе 7.x.x не заработал бы.
Спасибо:

Slepoy

Фотография
Дата: 01.04.2016
Ответить


Maniac Перейти
Slepoy, раз Quik 7.x.x завелся, значит и 7.1.2 заведется. И сервера Октрытие обновили, иначе 7.x.x не заработал бы.


Ты сотрудник Открывашки? Чего ж тогда ваша комапания уже полгода не обновляет клиентскую часть? 7ка вышла осенью, сейчас уже весна. Арка успела в этот период выпустить ещё одну версию 7.1, а Открывашка всё никак не торопится. Лично я поставлю старую версию 6.17. Я не собираюсь играть угадайку и рисковать баблом. Я высказал предположение об опасности, и оно полностью логически обосновано. И заявления " раз Quik 7.x.x завелся, значит и 7.1.2 заведется." вообще лишины логики, ибо в разработке ПО всё идёт как раз наоборот. Новые серверные версии обычно поддерживают старые клиетские, и то в рамках небольшого разброса старых версий, пока клиенты потихоньку обновлятся. Но никак не наоборот. Если версия 7.0 запускается, то 7.1. без обновления сервака не факт что заработает, всё зависит от разработчиков АРКИ, а не от наших хотелок. Новый МS Word, который Майкрософт выпустил в 2007 году, спокойно октрывал документы от старой версии. Но старый Ворд документы нового Ворда открывать не умеет ))). Ну это же прописные истины. Хочешь рисковать баблом - твоё право! Лично я не знаю какая у них серверная версия, и если клиентская у них 6.17, то и серверная по логике должна быть такой же.

А то что 7ка заработала, возможно АРКА замутила совместимость, или чего-то проморгала и это глюк, или действительно Открывашка установили новую серверную версию. Вот тебе 3 возможных вариантах. Лично я выберу 2й, ввиду возможных рисков. У меня нет достоверной информации о том, чего там установлено в Открывашке.
Спасибо:

kiaveryanov

Фотография
Дата: 02.04.2016
Ответить


Основной функционал работает, остальное мне не особенно важно... Буду решать проблемы по мере их возникновения =)
Автор топика
Спасибо:

Slepoy

Фотография
Дата: 02.04.2016
Ответить


kiaveryanov Перейти
Основной функционал работает, остальное мне не особенно важно... Буду решать проблемы по мере их возникновения =)


Тут же бабки на кону. Это не покупка чайника через непроверенный инет магаз. Зачем так рисковать, я не пойму никак. А если стоп не исполнится? Ну отправляется он, ну регистрируется, а вдруг в критический момент из-за возможного конфликта версий - сервер Квика его не исполнит. Или ПО сервера, даст глюк в расчёте маржи и откроет вам позу с не тем плечом, и не в ту сторону, и рисковики вас порежут по маржинколу, либо поймаете лося в несколько раз больше по объёму. Мы же трейдеры, контроль риска - это первооснова, а большинству, как я понял, вообще на это похрену ))). Ну хотя бы позвонить Открывашке и прямо спросить - какая у вас серверная часть, можно ведь. Либо отписаться на сайте АРКИ, с вопросом не будет ли конфликтов. Неужели вам всем - наплевать на своё бабло? Просто так рисковать, на основе простых домыслов и предположений - это же неразумно и недальновидно. Ну есть же возможность получить объективную обратную связь от АРКИ и Открывашки. Надо всего лишь набрать номер и позвонить + оставить вопрос на форуме АРКИ. Тут делов-то на полчаса. Но нет, всем жалко времени, и они рискуют на основе субъективной веры в "авось пронесёт" ))). То что сейчас на первый взгляд проблем не видно, вовсе не означает что их нет. Они могут вылезти там, где мы их совсем не ждём.
Спасибо:

kiaveryanov

Фотография
Дата: 02.04.2016
Ответить


Цитата:
А если стоп не исполнится?


У модуля терминала какая задача? Выставлять и убирать заявки, все. Для контроля за остальным есть другие модули, которые отлично сработают при известной внештатной ситуации. Завязывать все на только на модуль терминала - не самое верное решение при работе с деньгами =)
Автор топика
Спасибо:

Slepoy

Фотография
Дата: 02.04.2016
Ответить


kiaveryanov Перейти
У модуля терминала какая задача? Выставлять и убирать заявки, все. Для контроля за остальным есть другие модули, которые отлично сработают при известной внештатной ситуации. Завязывать все на только на модуль терминала - не самое верное решение при работе с деньгами =)


Задача у модуля терминала - отправлять заявки серверной части, и принимать от неё маркет-дату и обратную связь по заявкам, сделкам. С чего ты решил, что возможно старая серверная часть корректно будет отрабатывать все стадии при работе со новой клиентской частью? Может она некорректно примет стоп-заявку, либо отправит назад неверную инфу: мол заявка снята, а на самом деле она будет висеть, либо наоборот. Тут даже дополнительыне модули получающие обратную связь через тот же Квик - не помогут. Ты закатаешь дополнительынй модуль, но если он получает маркет-дату через тот же Квик 7.1, то тебе терминал и отобразит мол всё в порядке, а на деле будет всё иначе. Для контроля как минимум понадобиться МТ5, либо Плаза 2, либо второй независимый Квик висящий на другом серваке Окрывашки - и то там стопы не увидишь нигде, максимум проконтролируешь открытую позу. Тут с текущей то версией проблемы возникают: Открывашка, иногда то косячное время присылает со сдвигом +/- час, то ТВС присылает корявую и коллекция Trades не вся получается, да ещё и в перемешку с неупорядоченными сделками. Вот и хрен знает кто косячит: толи это API Стокшарпа, то ли Квик Открывашки. Кто виноват? Да, хрен его знает. Даже со штатным 6.17 какая-то хрень иногда получается, а ты предлашгаешь ещё ситуацию усугубить и закатать последнию версию Квика. Тогда вообще неизвестно на кого валить вину на: серверную часть Квика, клиентскую часть Квика, API стокашарпа, или на мои кривые руки ))). Я бы все понял, если бы АРКА и Открывашка - это официально подтвердили, что мол можно так делать и конфликтов не будет. Но я никогда не поставлю Квик 7.1, на основании лишь твоих субъективных умозаключений и домыслов. Вот был бы ты сотрудником АРКИ или Открывашки, то другое дело. Я бы слово против не сказал. А пока я останусь при своём мнении. Может всё у тебя и будет работать нормально. Но лично я рисковать не буду, я за консервативный безопасный подход.
Спасибо:

Maniac

Фотография
Дата: 02.04.2016
Ответить


Slepoy Перейти
Maniac Перейти
Slepoy, раз Quik 7.x.x завелся, значит и 7.1.2 заведется. И сервера Октрытие обновили, иначе 7.x.x не заработал бы.

Ты сотрудник Открывашки? Чего ж тогда ваша комапания уже полгода не обновляет клиентскую часть? 7ка вышла осенью, сейчас уже весна. Арка успела в этот период выпустить ещё одну версию 7.1, а Открывашка всё никак не торопится. Лично я поставлю старую версию 6.17. Я не собираюсь играть угадайку и рисковать баблом.


Я не сотрудник Открытия, и такая агрессия не совсем понятна :(
В инструкции по обновлении клиентской части Quik 7.0.x и 7.1.x есть минимальное требование для версии серверной части Quik. И раз 7.0.x запустился, значит Открытие серверную часть обновила. И если Открытие считает, что, выложив для клиентов Quik 7.0.x, они получат кучу звонков недовольных пользователей, то это их право, не выкладывать 7-ю версию.
И никого насильно использовать 7-ю версию я не призывал. Работает 6.х - замечательно. Список всех нововведений в 7.х можно узнать на сайте Арки и решить, надо обновляться или нет.

Спасибо:

Slepoy

Фотография
Дата: 02.04.2016
Ответить


Maniac Перейти
Я не сотрудник Открытия, и такая агрессия не совсем понятна :(
В инструкции по обновлении клиентской части Quik 7.0.x и 7.1.x есть минимальное требование для версии серверной части Quik. И раз 7.0.x запустился, значит Открытие серверную часть обновила. И если Открытие считает, что, выложив для клиентов Quik 7.0.x, они получат кучу звонков недовольных пользователей, то это их право, не выкладывать 7-ю версию.
И никого насильно использовать 7-ю версию я не призывал. Работает 6.х - замечательно. Список всех нововведений в 7.х можно узнать на сайте Арки и решить, надо обновляться или нет.


Да это не агрессия, это мое непонимание. Я пытаюсь понять откуда инфа. Если бы сразу сказал, что где-то прописано то, о чём ты говоришь, то я бы слова против не возразил. Вот только я не нашёл в инструкции то, что ты утверждаешь. Ты можешь дать точную ссылку где это описано? Я в инструкции нашёл только это:
Цитата:
1.7 Обновление версии программы
Система QUIK имеет встроенный механизм автоматического обновления версии программы.
При соединении программы клиента с сервером системы производится сверка модулей
программы и их версий на компьютере клиента с эталонной конфигурацией, размещенной
на сервере.
При обнаружении на сервере новых модулей программа предлагает произвести их прием
и установку. Таким образом, для обновления программы нет необходимости устанавливать
заново программу из дистрибутива, достаточно получить обновленные модули и позволить
системе QUIK установить их – нажмите кнопку «Принять файлы».
После загрузки файлов на компьютер клиента на экране появится предложение перезапустить
программу, чтобы записать новые файлы взамен прежних. Нажмите кнопку «Да». После
обновления программа предложит восстановить соединение с сервером и снова готова
к работе.


То о чём ты говоришь - я не обнаружил. И более того, сегодня порывшись на сайте АРКИ, я пришёл к выводу что походу действительно существует обратная совместимость. Походу новый терминал может коннектиться к старому серверу, ибо они разрабатывают серверную часть вообще отдельно, там даже нумерация иная )))
Сейчас самая новая серверная часть имеет номер 5.2.3.
Клиентские версии(даты выпуска)
Версия 7.1 (12.02.2016)
Версия 7.0 (07.10.2015)
Версия 6.17 (18.03.2015)

Серверные версии(даты выпуска)
Верси 5.2.3 (27.01.2016)
Версия 5.1 (17.11.2015)
Версия 5.0 (25.09.2015)
Версия 4.24 (29.07.2015)
Версия 4.23 (14.05.2015)
Версия 4.22 (09.04.2015)

На момент выхода Квика 7.0, у брокеров могла стоять лишь старая серверная часть 5.0 от 25.09.2015. Поэтому и получается такая совместимость. АРКА видать не модифицицирует передаваемые потоки данных. То есть, действительно всё должно работать без проблем. Новый Квик можно коннектить к старому серверу. И скорей всего Открывашка ничего не обновляла ибо это не к чему, хотя хрен его знает - может и обновила ради нового функционала по управлению рисками клиентов. В общем, мои опасения неоправдались.
Спасибо:

Maniac

Фотография
Дата: 04.04.2016
Ответить


Самый "старый" сервер для нового терминала - это 5.0
Сейчас последняя версия сервера 5.2.9 от 14.03.2016
Спасибо: Slepoy

shipa988

Фотография
Дата: 05.04.2016
Ответить


У меня брокер БКС, учебный QUIK.Скачанный пример "SamplePublic" stocksharp для соединения с Quik lua выдает только таблицу с инструментами и портфели. Не получает таблицу заявок,сделок,стоп заявок....Также созданные в программе заявки добавляются в самой программе но в Quik не отправляются(( Подскажите куда копать? Версия скачанного архива с примерами и Api StockSharp_4.3.13
Спасибо:

Slepoy

Фотография
Дата: 05.04.2016
Ответить


Maniac Перейти
Самый "старый" сервер для нового терминала - это 5.0
Сейчас последняя версия сервера 5.2.9 от 14.03.2016


Цитата:

Здравствуйте!
Мы подготовили для Вас обновление версии Рабочего места
QUIK 7.1.2
Описание всех изменений в версии 7.1.2 содержится в приложенном файле
"Изменения в Рабочем месте QUIK 7.1.2.pdf".

УСТАНОВКА И НАСТРОЙКА ОБНОВЛЕНИЯ

ВНИМАНИЕ!!! Новая версия Рабочего места 7.1.2 поддерживается только
серверной частью QUIK версии 5.0 и выше.

Перед тем как установить обновление Рабочего места, убедитесь
в том, что обновление Сервера версии 5.0 или выше было
Вами установлено. Версию Сервера Вы можете посмотреть
в программе QMonitor: в разделе с деревом серверов доступа
в левом разделе таблицы "User table".

Распакуйте присланные файлы и скопируйте их в директории
QUIK\Front\
QUIK\Server\areas\Frontend\Release\
на компьютере с сервером QUIK.

Напоминаем наши координаты:
тел.: +7(383)-219-1606
тел. в Украине: 0800-500-037
email: quiksupport@arqatech.com

Убедительная просьба писать все письма именно на этот адрес,
чтобы исключить задержки с ответом с нашей стороны по причине
командировок, болезней и т.п. конкретных сотрудников.
Также мы были бы рады рассмотреть предложения и пожелания по
доработкам ПО, присланные на тот же адрес электронной почты.

Если возникнут какие-либо вопросы, обращайтесь, будем рады Вам помочь!

С уважением, команда разработки и поддержки QUIK.



А как подписаться на такую же рассылку АРКИ? Я так понял, это что-то вроде для тестировщиков или брокеров? Я прав?
Из письма следует, что нужно через прогу QMonitor узнать версию сервака. А программа QMonitor - это как раз часть серверного ПО.
QMonitor - нет в клиентских терминалах. Следовательно, данное письмо точно не для простых смертных пользователей.
Спасибо:
1 2  >

Добавить файлы через драг-н-дроп, , или вставить из буфера обмена.

loading
clippy