Лицензия не поддерживает HydraQuikTrader
Atom Ответить
18.06.2014


Доброе время суток, господа. При попытке получить стаканы и изменения из квика Гидра ругается сабжем, что делать? :)

Теги:


Спасибо:




14 Ответов
Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 18.06.2014
Ответить


Oldman Перейти
Доброе время суток, господа. При попытке получить стаканы и изменения из квика Гидра ругается сабжем, что делать? :)


Как вариант - лицензию установить.
Спасибо:

Oldman

Фотография
Дата: 18.06.2014
Ответить


Михаил Сухов Перейти
Oldman Перейти
Доброе время суток, господа. При попытке получить стаканы и изменения из квика Гидра ругается сабжем, что делать? :)


Как вариант - лицензию установить.


Увы, этот вариант попробовал первым делом.
Лицензия установленна корректна, так как stocksharp QuikTrader работает :)
Автор топика
Спасибо:

GSC2

Фотография
Дата: 19.06.2014
Ответить


Ога, не только Гидра ругается, но и смарт, и плаза. Сегодня решил потестить на другом компе, сгенерил новые лицензии, пишет, что неподдерживает СмартТрейдер, по Плазе - пишет, что не подключен какой-то COM, хотя на другом компе теже смарт и плаза работют корректно, но там оформленная месяц назад.
Спасибо:

Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 19.06.2014
Ответить


Попробуйте заново сгенерировать лицензию.
Спасибо:

GSC2

Фотография
Дата: 19.06.2014
Ответить


Тоже самое - "не поддерживает SmartTrader"
Заметил разницу в напиcании<features>:
Где корректно работает -
<features>QuikTrader,PlazaTrader,AlfaTrader,SmartTrader,EmulationTrader,DataFeedTrader,TransaqTrader,AlorTrader,ETradeTrader,LmaxTrader,IQFeedTrader,FixTrader,Quik,Plaza,AlfaDirect,SmartCOM,Transaq,Alor,...</features>
новая лицензия - <features>Quik,Plaza,AlfaDirect,SmartCOM,DataFeed,Transaq,Alor,ETrade,Lmax,IQFeed,Fix,...</features>
в новой лицензии не видно ни PlazaTrader, ни SmartTrader, в предыдущей(рабочей) есть.
Использую сборку 4.2.2.16
Спасибо:

Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 19.06.2014
Ответить


GSC2 Перейти

Использую сборку 4.2.2.16


Попробуйте обновить тогда, раз обновление лицензии не помогло.
Спасибо:

GSC2

Фотография
Дата: 19.06.2014
Ответить


Уже разобрался. Именно из-за сборки. Понимаю, что у вас "агрессивный рост" - новые фичи, новые платформы, работы оч много, но сохранять приемственность хотя бы по части лицензии можно бы) Получается с "каждым" обновлением нужно скачивать новые сборки, исправлять исправления, перекомпилировать... только из-за нового формата лицензии)
Спасибо:

Oldman

Фотография
Дата: 24.06.2014
Ответить


Перегенерил несколько раз лицензию, каждый раз
Лицензия не поддерживает HydraQuikTrader
Crying Crying
Автор топика
Спасибо:

Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 24.06.2014
Ответить


Версия Гидры последняя?
Спасибо:

Oldman

Фотография
Дата: 25.06.2014
Ответить


Михаил Сухов Перейти
Версия Гидры последняя?


4.1.19.1
на обоих компах. На одном все работает, на другом ошибка лицензии гидры, но трейдер работает.

Обновлять гидру или api не хочется, поскольку как обычно с обновлением перестает работать все что сделано раньше :)
Автор топика
Спасибо:

Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 25.06.2014
Ответить


Oldman Перейти
Михаил Сухов Перейти
Версия Гидры последняя?


4.1.19.1
на обоих компах. На одном все работает, на другом ошибка лицензии гидры, но трейдер работает.

Обновлять гидру или api не хочется, поскольку как обычно с обновлением перестает работать все что сделано раньше :)


Как хотите. Вы спросили причину - я ответил решение. Принимать лечение или нет дело больного.BigGrin
Спасибо: Oldman

Oldman

Фотография
Дата: 25.06.2014
Ответить


Михаил Сухов Перейти


Как хотите. Вы спросили причину - я ответил решение. Принимать лечение или нет дело больного.BigGrin


Благодарю за ответы :)
Автор топика
Спасибо:

Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 25.06.2014
Ответить


Покупайте обучение или корп версию (100% защита от смены лиц политики). Если бы вы были учеником, то я бы конечно напрягься, чтобы сгенерировать для вас старый формат лицензии. Но так как вы ничего не купили, и пользуетесь бесплатно, то желания как-то не особо много.

Помогайте проекту хоть как-то. Тогда проект начнет помогать и вам.Wink
Спасибо: Oldman

Виктор

Фотография
Курсы Благотворитель
Дата: 28.02.2015
Ответить


День добрый! При попытке запустить S#Data v4.1.9.0 для закачивания с Quik пишет, что Лицензия не поддерживает HydraQuikTrader.
Запуск LicenseTool_4.1.19.1 ни к чему хорошему не привел, еще раньше ставил лицензию по S# Studio и S#Data 4.2.43.

Я решил сначала все протестировать, чтобы что-то начать делать, но так получается, что любое решение которое сам напишешь, используя HydraQuikTrader, в прекрасный момент встанет колом, лишь потому что-то там не то с файлом лицензии?

Да и любые другие компоненты, которые даже входят в базовую лицензию, просто со временем перестанут работать. Ерунда какая- то получается.


Спасибо:


Добавить файлы через драг-н-дроп, , или вставить из буфера обмена.

loading
clippy