Студия что-то делает)
Atom Ответить
08.04.2013


Сразу после старта начинает по полной грузить одно из ядер процессора.. соответственно жутко тормозит гуи.. пробовал ждать, но ничего не меняется.. обращений ни к диску, ни к сети нет.. в логах пусто.. как узнать чем она занята?

Теги:


Спасибо:




11 Ответов
VassilSanych

Фотография
Дата: 08.04.2013
Ответить


Спасибо:

Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 08.04.2013
Ответить


XMbIPb Перейти
Сразу после старта начинает по полной грузить одно из ядер процессора..


Просто запустили студию, ничего в ней не нажимая?
Спасибо:

XMbIPb

Фотография
Дата: 08.04.2013
Ответить


Mikhail Sukhov Перейти

Просто запустили студию, ничего в ней не нажимая?

Да
Автор топика
Спасибо:

Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 08.04.2013
Ответить


XMbIPb Перейти
Mikhail Sukhov Перейти

Просто запустили студию, ничего в ней не нажимая?

Да


Это первый запуск? Может быть что-то все таки в ней запустили?
Спасибо:

XMbIPb

Фотография
Дата: 08.04.2013
Ответить


Mikhail Sukhov Перейти

Это первый запуск? Может быть что-то все таки в ней запустили?

Запуск не первый.. не заметил когда это началось..
Стратегии остановлены.. подключений нет.. что ещё может быть запущено?

Автор топика
Спасибо:

XMbIPb

Фотография
Дата: 09.04.2013
Ответить


Даже если удалить все пользовательские данные, нагрузка падает только наполовину.. мне кажется тут какая-то запара с фреймворком.. потому что если долго пялиться в монитор производительности, то можно заметить как периодически проскакивают запросы к C:\Windows\assembly\NativeImages_v4.0.30319_32\ и к C:\Windows\Microsoft.NET\Framework\v4.0.30319\
Автор топика
Спасибо:

esper

Фотография
Программист
Дата: 09.04.2013
Ответить


Т.е. удаляется полностью папка MyDoc\StockSharp\Studio ?
Спасибо:

XMbIPb

Фотография
Дата: 09.04.2013
Ответить


Да.. даже если её удалить загрузка проца сохраняется.. в теории, после первого запуска и создания новой бд, загрузка должна падать до нуля?
Проверил на трёх машинах(8ка 64бит и 2012й сервер 64бит) везде, после первого запуска, студия начинает отъедать ~7-8% проца вхолостую и чем дольше в ней работаешь, тем ближе этот процент к ста.. на 32х битных осях такая хрень не наблюдается?
Автор топика
Спасибо:

XMbIPb

Фотография
Дата: 17.04.2013
Ответить


В 4.1.11.1 проблема сохранилась.. и в 64х и в 32х битной версии...
Автор топика
Спасибо:

esper

Фотография
Программист
Дата: 17.04.2013
Ответить


XMbIPb Перейти
Да.. даже если её удалить загрузка проца сохраняется.. в теории, после первого запуска и создания новой бд, загрузка должна падать до нуля?

У меня на чистой студии в простое загрузка 1-2%
XMbIPb Перейти
Проверил на трёх машинах(8ка 64бит и 2012й сервер 64бит) везде, после первого запуска, студия начинает отъедать ~7-8% проца вхолостую и чем дольше в ней работаешь, тем ближе этот процент к ста.. на 32х битных осях такая хрень не наблюдается?

А какое железо?
Спасибо:

XMbIPb

Фотография
Дата: 17.04.2013
Ответить


Ноут athlon x2(4gb),комп athlon2 x3(8gb), ну и планшет intel atom(2gb)...
Засада в том, что этот % постоянно растет.. вот на ноуте сегодня только переустановил.. соединение настроил, стратегию компильнул.. а загрузка уже >30% вхолостую...
А у вас этот 1-2% откуда берётся не выясняли?
Автор топика
Спасибо:


Добавить файлы через драг-н-дроп, , или вставить из буфера обмена.

loading
clippy