Проблемы при переходе с 4.1.6 на 4.1.8
Atom Ответить
27.02.2013


Решил обновиться на новую версию. В коде почти ничего менять не пришлось.
При запуске сначала вылетела ошибка с лицензией: "Лицензионный файл содержит неправильный идентификатор компьютера BFEBFBFF000206A7 вместо BFEBFBFF000206A71C:6F:65:D7:82:D0", что странно, комп тот же.
Зашел в свой личный кабинет, создал лицензию для указанного идентификатора, вроде прокатило.
Далее при попытке коннекта со всех потоков вылетает ошибка COMException с библиотеки P2ClientGateMTA64 (см. прикрепленный файл). Сброс Ini файлов у робота и переустановка гейта на более свежий не помогла.
error.JPG 60,9KB (0)

Теги:


Спасибо:




5 Ответов
Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 27.02.2013
Ответить


FiNick Перейти
Далее при попытке коннекта со всех потоков вылетает ошибка COMException с библиотеки P2ClientGateMTA64 (см. прикрепленный файл). Сброс Ini файлов у робота и переустановка гейта на более свежий не помогла.


Раньше помогало.
Спасибо:

FiNick

Фотография
Благотворитель
Дата: 27.02.2013
Ответить


Позапускал ваш пример SampleGUI, версия 4.1.6 работает норм. Версии 4.1.7 и 4.1.8, во-первых, требуют нового файла лицензии(это так надо?), во-вторых, летят эти ошибки со всех потоков. Использую гейт P2_ClientGate1.14.8_64.
Ini файлы с папки SampleGUI\bin\Debug\StockSharp_Plaza\Configs удаляю все, не помогает.
Автор топика
Спасибо:

esper

Фотография
Программист
Дата: 27.02.2013
Ответить


FiNick Перейти
Использую гейт P2_ClientGate1.14.8_64.

Попробуйте версию поновее, как минимум есть P2_ClientGate1.14.11_64.
Спасибо:

FiNick

Фотография
Благотворитель
Дата: 27.02.2013
Ответить


Установка P2_ClientGate1.14.11_64 помогла, спасибо!
Такой момент: при запуске этот гейт пишет "Couldn't load library 'P2DBSQLite3.dll' : '126-'The specified module could not be found", но работает вроде. У кого-нибудь такой же глюк есть?
Автор топика
Спасибо:

yammm

Фотография
Дата: 07.03.2013
Ответить


FiNick Перейти
Установка P2_ClientGate1.14.11_64 помогла, спасибо!
Такой момент: при запуске этот гейт пишет "Couldn't load library 'P2DBSQLite3.dll' : '126-'The specified module could not be found", но работает вроде. У кого-нибудь такой же глюк есть?


Аналогично. Но вроде все работает.

Спасибо:


Добавить файлы через драг-н-дроп, , или вставить из буфера обмена.

loading
clippy