Exception при обращении к Security.BestPair
Atom Ответить
21.01.2013


приветствую!

В коде робота есть такая строчка:

extInfo.Add("placement.quote", sc.BestPair);

После обновления на версию 4.1.6 на этой строчке вылетает исключение:

Оффер может быть только на продажу. at StockSharp.BusinessEntities.MarketDepthPair..ctor(Security security, Quote bid, Quote ask)
at StockSharp.BusinessEntities.Security.get_BestPair()

в чем может быть причина?



Теги:


Спасибо:




2 Ответов
l-way

Фотография
Дата: 21.01.2013
Ответить


l-way Перейти
приветствую!

В коде робота есть такая строчка:

extInfo.Add("placement.quote", sc.BestPair);

После обновления на версию 4.1.6 на этой строчке вылетает исключение:

Оффер может быть только на продажу. at StockSharp.BusinessEntities.MarketDepthPair..ctor(Security security, Quote bid, Quote ask)
at StockSharp.BusinessEntities.Security.get_BestPair()

в чем может быть причина?




подключаюсь к quik, версия 6.3.2.2
Автор топика
Спасибо:

Alexander

Фотография
Дата: 25.01.2013
Ответить


На 4.1.7 воспроизводится? Ошибка говорит о том, что у вас почему-то Ask.OrderDirection - Buy, а не Sell.
Что, естественно, невозможно.

Если воспроизводится - покажите как получаете стакан.
Спасибо:


Добавить файлы через драг-н-дроп, , или вставить из буфера обмена.

loading
clippy