зависание при отправке первой транзакции
Atom Ответить
23.03.2012


Товарищи разработчики, не знаю может проблема на моей стороне, но чтобы вы были в курсе напишу о проблеме.

При отправке первой транзакции зависает работа робота, пробовал регистрировать и через обычную заявку и через котирование, и даже пробовал через SampleGUI "Новая заявка" ситуация везде одинаковая идет зависание на 20 сек. (и более) после чего регистрация заявок проходит без задержек.
Пробовал версии 4.014, 4.020, 4.1 (из транка)
Плаза - тестовый контур
Замечали ли вы эту проблему? или она исключительно у меня возникает?

Теги:


Спасибо:




14 Ответов
Alexander

Фотография
Дата: 23.03.2012
Ответить


не замечал
Спасибо:

hurricane

Фотография
Дата: 23.03.2012
Ответить


попробую на другом компе тогда! так пример пробовал и через SampleGUI без изменения
Автор топика
Спасибо:

sergun

Фотография
Дата: 26.04.2012
Ответить


hurricane Перейти
попробую на другом компе тогда! так пример пробовал и через SampleGUI без изменения


А меня на "боевой" стабильно время между входом и выходом из RegisterOrder при первом обращении ~ 3-4 сек.

Бяда :-)
Спасибо:

Alexander

Фотография
Дата: 26.04.2012
Ответить


sergun Перейти
hurricane Перейти
попробую на другом компе тогда! так пример пробовал и через SampleGUI без изменения


А меня на "боевой" стабильно время между входом и выходом из RegisterOrder при первом обращении ~ 3-4 сек.

Бяда :-)



Это какая версия?
Спасибо:

sergun

Фотография
Дата: 26.04.2012
Ответить


Alexander Mukhanchikov Перейти
sergun Перейти
hurricane Перейти
попробую на другом компе тогда! так пример пробовал и через SampleGUI без изменения


А меня на "боевой" стабильно время между входом и выходом из RegisterOrder при первом обращении ~ 3-4 сек.

Бяда :-)



Это какая версия?


4.1.0.0

Причем со временем ошибся - не 3-4 секунд, а 3-4 МИНУТ.
Спасибо:

hurricane

Фотография
Дата: 26.04.2012
Ответить


Цитата:
4.1.0.0

Причем со временем ошибся - не 3-4 секунд, а 3-4 МИНУТ.


на мощном компьютере (сервер) проблема устранилась (первая транзакция около 300мс, средняя 100мс), проблема была на ноутбуке, может и у Вас в этом проблема?
Автор топика
Спасибо:

sergun

Фотография
Дата: 26.04.2012
Ответить


hurricane Перейти
Цитата:
4.1.0.0

Причем со временем ошибся - не 3-4 секунд, а 3-4 МИНУТ.


на мощном компьютере (сервер) проблема устранилась (первая транзакция около 300мс, средняя 100мс), проблема была на ноутбуке, может и у Вас в этом проблема?


Не, у меня мощный )))
Спасибо:

Alexander

Фотография
Дата: 26.04.2012
Ответить


sergun Перейти
Alexander Mukhanchikov Перейти
sergun Перейти
hurricane Перейти
попробую на другом компе тогда! так пример пробовал и через SampleGUI без изменения


А меня на "боевой" стабильно время между входом и выходом из RegisterOrder при первом обращении ~ 3-4 сек.

Бяда :-)



Это какая версия?


4.1.0.0

Причем со временем ошибся - не 3-4 секунд, а 3-4 МИНУТ.


Какая версия конкретно?
С какого коммита скачивали с dev?

Какие-то подозрительные у вас данные.
Это синк или асинк?
Спасибо:

Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 26.04.2012
Ответить


sergun Перейти
Причем со временем ошибся - не 3-4 секунд, а 3-4 МИНУТ.


Начнем с простого. SampleGUI запускали? Регистрацию заявки делали в нем? Так же 3-4 минуты?
Спасибо:

Justtrader

Фотография
Дата: 26.04.2012
Ответить


Действительно наблюдается небольшой тормоз при отправке самой первой транзакции, причем наблюдался всегда. Только, не в несколько минут, а где-то в 50-150 мс.
Спасибо:

sergun

Фотография
Дата: 26.04.2012
Ответить


Alexander Mukhanchikov Перейти
sergun Перейти
Alexander Mukhanchikov Перейти
sergun Перейти
hurricane Перейти
попробую на другом компе тогда! так пример пробовал и через SampleGUI без изменения


А меня на "боевой" стабильно время между входом и выходом из RegisterOrder при первом обращении ~ 3-4 сек.

Бяда :-)



Это какая версия?


4.1.0.0

Причем со временем ошибся - не 3-4 секунд, а 3-4 МИНУТ.


Какая версия конкретно?
С какого коммита скачивали с dev?

Какие-то подозрительные у вас данные.
Это синк или асинк?


Какая версия конкретно не помню. Архив с номером коммита не сохранился.
Подозрительное тут вряд ли что-то может быть. Сообщение в лог непосредственно до RegisterOrder и сразу после.

В плане асинхронного - неасинхронного режима - я его не задаю, насколько знаю д.б. при этом асинхронным.

Возможно вас наведет на догадку тот факт, что попытка отослать первую заявку происходит в скором времени после получения начальных снепшотов..
Но трудно предположить как это может повлиять на 3-х минутный невозврат из RegisterOrder
Спасибо:

Alexander

Фотография
Дата: 26.04.2012
Ответить


Скачайте последнюю 4.1, откройте SampleGui, пошлите заявку.
Какая задержка? 4 минуты? Покажите конкретно лог, который это продемонстрирует
Спасибо:

sergun

Фотография
Дата: 26.04.2012
Ответить


Alexander Mukhanchikov Перейти
Скачайте последнюю 4.1, откройте SampleGui, пошлите заявку.
Какая задержка? 4 минуты? Покажите конкретно лог, который это продемонстрирует


Проблема проявляется только на боевой Плазе. На ней нет возможности тестировать примерчики.
На Т-полигоне все всегда ок.

Лог никакой дополнительной информации в данном случае не даст.
Спасибо:

Alexander

Фотография
Дата: 26.04.2012
Ответить


sergun Перейти
Alexander Mukhanchikov Перейти
Скачайте последнюю 4.1, откройте SampleGui, пошлите заявку.
Какая задержка? 4 минуты? Покажите конкретно лог, который это продемонстрирует


Проблема проявляется только на боевой Плазе. На ней нет возможности тестировать примерчики.
На Т-полигоне все всегда ок.

Лог никакой дополнительной информации в данном случае не даст.


Ok, тогда остаёмся при мнении что у вас локальная проблема и связана с неверным использованием шлюза.
SampleGui работает как надо, ищите у себя проблему из-за чего задержки по 4 минуты возникают.

Советую за основу взять как раз SampleGui.


P.S. А тестировать можно посылая заявку далеко вне рынка. Это если что, на будущее. И при этом вы не потеряете ни рубля.
Спасибо:


Добавить файлы через драг-н-дроп, , или вставить из буфера обмена.

loading
clippy