Возможны ли конфликты разных версий S#?
Atom Ответить
04.10.2011


Ситуация такая: есть робот на S# 3.0 для квика, хорошо отработан, несколько месяцев стабильной работы.
Запускаю одновременно с первым другого робота, на S# 4.0 для плазы. Через пару часов в первом роботе вылетает какая-то странная несуразная ошибка, мол такая-то переменная типа Order равна null, а я с ней что-то сделать пытаюсь, копаюсь в коде, ошибки не нахожу, все норм должно быть.
Через пол часа уже в роботе для плазы вылетает ошибка, тоже null exception связанная с каким-то ордером, опять же покопался в коде найти ошибку не смог.

Подозреваю конфликты dll

Теги:


Спасибо:




2 Ответов
Alexander

Фотография
Дата: 04.10.2011
Ответить


StackTrace необходим и что за заявка.
Вообще таких конфликтов быть не может.
Спасибо:

FiNick

Фотография
Благотворитель
Дата: 04.10.2011
Ответить


Пока не получается воспроизвести ошибку, т.к. захожу в позицию оч редко. Если еще раз появится буду думать.
Автор топика
Спасибо:


Добавить файлы через драг-н-дроп, , или вставить из буфера обмена.

loading
clippy