vs2010 express - папки решений не поддерживаются
Atom Ответить
10.09.2011


Поставил VS2010 express, пробую открыть verifier, чтобы собрать решение.
Вижу на экране:
"Папки решений не поддерживаются в этой версии приложения. Папка решений "Common" будет отображаться как недоступная."
Аналогичные сообщения по папкам Options, Quik, Smart, Testing, AlfaDirect, Plaza.
Далее еще сообщение:
"Решение уже содержит элемент с именем "SampleGUI". Один или несколько проектов в решении не были правильно загружены."
Что делаю неправильно и как исправить?
Система win server 2008 r2 64bit со всеми обновлениями. Framework 4.0.

Теги:


Спасибо:




13 Ответов
Alexander

Фотография
Дата: 10.09.2011
Ответить


Ignat Перейти
Поставил VS2010 express, пробую открыть verifier, чтобы собрать решение.
Вижу на экране:
"Папки решений не поддерживаются в этой версии приложения. Папка решений "Common" будет отображаться как недоступная."
Аналогичные сообщения по папкам Options, Quik, Smart, Testing, AlfaDirect, Plaza.
Далее еще сообщение:
"Решение уже содержит элемент с именем "SampleGUI". Один или несколько проектов в решении не были правильно загружены."
Что делаю неправильно и как исправить?
Система win server 2008 r2 64bit со всеми обновлениями. Framework 4.0.



Поставьте полную версию, а не express.
Папки не поддерживаются - значит что вложенные в проект папки не могут быть отображены.
Спасибо:

Ignat

Фотография
Дата: 10.09.2011
Ответить


Экспресс ставил, потому что на него сразу вывела ссылка из документации S#.
Вроде бы Сухов на вебинаре говорил, что 3 года кодил на экспрессе (говорю по памяти, могу ошибаться) или бесплатной версии экспресс будет недостаточно для работы с S#?
Или есть бесплатная полная версия VS2010?
Автор топика
Спасибо:

Alexander

Фотография
Дата: 10.09.2011
Ответить


Ignat Перейти
Экспресс ставил, потому что на него сразу вывела ссылка из документации S#.
Вроде бы Сухов на вебинаре говорил, что 3 года кодил на экспрессе (говорю по памяти, могу ошибаться) или бесплатной версии экспресс будет недостаточно для работы с S#?
Или есть бесплатная полная версия VS2010?


Будет достаточно, просто папки в проектах создавать не сможете.
В интернете всё есть, Windows бесплатные есть. Visual Studio - тем более. Cool
Спасибо:

Ignat

Фотография
Дата: 10.09.2011
Ответить


Винда стоит лицензионная, потому не хочется на нее левак ставить )
То есть verifier соберется в решение и в экспрессе, несмотря на невозможность подключения этих папок?
Автор топика
Спасибо:

Alexander

Фотография
Дата: 10.09.2011
Ответить


Ignat Перейти
Винда стоит лицензионная, потому не хочется на нее левак ставить )
То есть verifier соберется в решение и в экспрессе, несмотря на невозможность подключения этих папок?


Должен, да.

Тогда можно купить, вот тут
Либо пользоваться иными средствами разработки для C#
Спасибо:

Ignat

Фотография
Дата: 10.09.2011
Ответить


Желание покупать пока не одолевает )
Насколько альтернативные средства разработки адекватны?
Автор топика
Спасибо:

Alexander

Фотография
Дата: 10.09.2011
Ответить


Ignat Перейти
Желание покупать пока не одолевает )
Насколько альтернативные средства разработки адекватны?


Попользуйтесь, отпишитесь. Или гугл в помощь. :)
У меня опыта использывания не было.
Спасибо:

Ignat

Фотография
Дата: 10.09.2011
Ответить


Учитывая, что сравнить мне будет не с чем, остановлюсь на 90-дневном пробном VS2010 prof. )
А с framework 4.0 не будет проблем?
В одной из тем здесь было написано, что надо 3.5, либо удалять клиентский профиль в 4.0.
Автор топика
Спасибо:

Alexander

Фотография
Дата: 10.09.2011
Ответить


Ignat Перейти
Учитывая, что сравнить мне будет не с чем, остановлюсь на 90-дневном пробном VS2010 prof. )
А с framework 4.0 не будет проблем?
В одной из тем здесь было написано, что надо 3.5, либо удалять клиентский профиль в 4.0.


Надо собирать под .Net Framework 4.0, а не под 4.0 Client Profile.
Либо под 3.5

У меня все роботы - под 4.0 собраны.
Спасибо:

Ignat

Фотография
Дата: 10.09.2011
Ответить


Александр, если не сложно, поясните чайнику - что значит собрать под .Net Framework 4.0, а не под 4.0 Client Profile?
При попытке собрать express спрашивал - пересобрать ли под 4.0, но не спрашивал, под .Net Framework 4.0 или под 4.0 Client Profile.
4.0 Client Profile надо удалить совсем? Чтобы его удалить, надо удалить и 4.0 Expand - это нормально?
Автор топика
Спасибо:

Alexander

Фотография
Дата: 10.09.2011
Ответить


Ignat Перейти
Александр, если не сложно, поясните чайнику - что значит собрать под .Net Framework 4.0, а не под 4.0 Client Profile?
При попытке собрать express спрашивал - пересобрать ли под 4.0, но не спрашивал, под .Net Framework 4.0 или под 4.0 Client Profile.
4.0 Client Profile надо удалить совсем? Чтобы его удалить, надо удалить и 4.0 Expand - это нормально?


В свойствах проекта в Visual Studio открываете Application и выбираете Target framework.
Спасибо:

Ignat

Фотография
Дата: 10.09.2011
Ответить


Спасибо.
Автор топика
Спасибо:

Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 10.09.2011
Ответить


Ignat Перейти
Вроде бы Сухов на вебинаре говорил, что 3 года кодил на экспрессе


И это были отнюдь не самые лучшие годы в плане программирования.Laugh

Ignat Перейти
(говорю по памяти, могу ошибаться) или бесплатной версии экспресс будет недостаточно для работы с S#?


Будет вполне достаточно. Только вот sln с примера вы не откроете. Больше ограничений пока не вижу.
Спасибо:


Добавить файлы через драг-н-дроп, , или вставить из буфера обмена.

loading
clippy