Не получается получить истинное order.id заявки в последней версии Quik


Не получается получить истинное order.id заявки в последней версии Quik
Atom Ответить
14.09.2020


Обновил Quik до 8.8.4.3. Обновил StockSharp.Algo до 5.0.34. Спасибо разработчикам, все работает. За исключением одной маленькой, но важной детали.

Получаю событие NewOrder(order) и запоминаю order в внутренней памяти.
Потом, в случае необходимости пытаюсь удалить этот ордер с помощью команды CancelOrder, но он не удаляется.
Причина ясна - order.id на одну и ту же заявку в Quik и получаемый по NewOrder - разные . Если подставить order.id, который я возьму из таблицыQuick, то заявка удалится.
Проблема - как получить истинный order.id заявки?!
Заметил, что order.id, получаемый в NewOrder, и в таблице Quik на ту же заявку различаются незначительно, например
1 960 780 981 556 313 148 - в NewOrder
1 960 780 981 556 313 196 - в Quik

Спасибо!

Исправлено
5.0.31



Спасибо:




11 Ответов
Support

Фотография
Дата: 14.09.2020
Ответить


Добрый день

Включите, пожалуйста, в LUA и роботе уровень логирования Verbose и пришлите логи на почту support@stocksharp.com
Спасибо:

v3Rtex

Фотография
Дата: 14.09.2020
Ответить


Аналогичная проблема
Спасибо:

Михаил

Фотография
Дата: 15.09.2020
Ответить


Имею проблему что transaction id в коннекторе lua подставляется неправильный

t["CLASSCODE"] = "SPBFUT"
t["SECCODE"] = "EDZ0"
t["ORDER_KEY"] = "1963314260641714944"
t["ACTION"] = "KILL_ORDER"
t["TRANS_ID"] = "54980831"
return sendTransaction(t)

из-за этого не может снять заявку в квике.

Quik 8.8.4.3, пробую снимать ордер в примере SampleConnection
Спасибо:

Support

Фотография
Дата: 15.09.2020
Ответить


LevNNN Перейти



Добрый день

Попробуйте новую версию.
Спасибо:

Михаил

Фотография
Дата: 15.09.2020
Ответить


Обновил по нугету всё что дало обновить.
Всё равно проблема со снятием заявки.
Спасибо:

LevNNN

Фотография
Дата: 15.09.2020
Ответить


К сожалению подтверждаю, что ошибка осталась.
Автор топика
Спасибо:

Support

Фотография
Дата: 15.09.2020
Ответить


LevNNN Перейти
К сожалению подтверждаю, что ошибка осталась.


У вас продолжает транслироваться неправильный номер? Вы обновили Lua коннектор?
Спасибо:

v3Rtex

Фотография
Дата: 15.09.2020
Ответить


Support Перейти
LevNNN Перейти



Добрый день

Попробуйте новую версию.


Спасибо! Своевременно)
Проблема ушла
Спасибо:

v3Rtex

Фотография
Дата: 15.09.2020
Ответить


LevNNN Перейти
К сожалению подтверждаю, что ошибка осталась.


А вы в квике обновили библиотеки?
Спасибо:

LevNNN

Фотография
Дата: 15.09.2020
Ответить


Виноват - обновил Lua и заработало. Спасибо разработчикам!
Автор топика
Спасибо:

Михаил

Фотография
Дата: 15.09.2020
Ответить


я тоже кажется разобрался
нужно было добавить два коннектора луа и ничего не менять в них.
Спасибо:


Добавить файлы через драг-н-дроп, , или вставить из буфера обмена.

loading
clippy