Не могу настроить экспорт по DDE
Atom Ответить
15.09.2010


Здравствуйте!
Неделю бьюсь над всеми возможными способами поймать проблему:
у меня стоит QUIK 5.17.0.159, загрузил настройки из дистрибутива S#
(info_sample_dde_extended). Проверил утилитой Verifier, показал одну
ошибку, исправил - всё отлично - выводится сообщение, что всё
настроено правильно. Дальше запускаю пример Sample, успешно
подключаюсь к QUIK, начинаю экспорт и на первой же таблице
(Инструменты) QUIK выдает ошибку, мол:
"Не удалось установить DDE соединение с сервером 'wrapper'. Либо не
запущен 'инструменты', либо в него не загружен лист ''Таблица
'Инструменты'".
Примечательно, что не все таблицы выдают такие ошибки. Сам код Sample
никаких эксепшенов не выдает.
В чем может быть проблема - не пойму.
До этого момента пробовал настроить таблицы самостоятельно - была одна
ошибка в названиях столбцов (вместо Количество бумаг в последней
сделаке у меня в QUIK был столбец Количество в последней сделке),
результат аналогичный - экспорт не начинался.

Теги:


Спасибо:




5 Ответов
Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 15.09.2010
Ответить


А что за ОС? Квик и привет запускаются под одной учеткой?

Спасибо:

Андрей Соловьев

Фотография
Дата: 16.09.2010
Ответить


ОС: MS Windows 7 Professional
Что имелось ввиду под "привет"? Учетная запись в квике у меня одна,
да.

Автор топика
Спасибо:

Mikhail Sukhov

Фотография
Автор статей Программист Трейдер
Дата: 16.09.2010
Ответить


Описка. Думаю об одном, пишу другое.

В семерке надо Квик запускать под адиминстративными привелегиями.
Робот под такими же запускаете?

Спасибо:

Иванов Андрей

Фотография
Дата: 17.09.2010
Ответить


Второй или третий раз уже встречаю требование запуска Квика под
админом.
Запускать надо только один раз, дальше запускается под обычным
пользователем. Это с Висты так, из-за диссонанса Квика и включенного
UAC.

Без этого одного запуска под админом Квик весь работает криво, и без
внешних транзакций.

Спасибо:

Андрей Соловьев

Фотография
Дата: 17.09.2010
Ответить


Совет с правами администратора помог, спасибо, всё заработало!
Только всё же приходится каждый раз запускать от админа. При запуске
второй раз под обычным пользователем проблема возобновляется.

Автор топика
Спасибо:


Добавить файлы через драг-н-дроп, , или вставить из буфера обмена.

loading
clippy