Не запускается lua скрипт
Atom
16.07.2014


Действовал согласно инструкции, все настройки скрипта дефолтные.
При загрузке скрипта в Квик вылетает следующая ошибка: Unknown error. Possible unhandled exception.
Код

[16.07.2014 00:31:37] StockSharp.Logging, Version=4.2.8.0, Culture=neutral, PublicKeyToken=null: System.NotSupportedException: An attempt was made to load an assembly from a network location which would have caused the assembly to be sandboxed in previous versions of the .NET Framework. This release of the .NET Framework does not enable CAS policy by default, so this load may be dangerous. If this load is not intended to sandbox the assembly, please enable the loadFromRemoteSources switch. See ÷ñÒ63134917êÖ0õæ÷http://go.microsoft.com/fwlink/?LinkId=155569 ÷ñÒ63134917êÖ1õæ÷for more information.
   at System.Reflection.RuntimeAssembly.nLoadFile(String path, Evidence evidence)
   at System.Reflection.Assembly.LoadFile(String path)
   at CurrentDomain_AssemblyResolve(Object sender, ResolveEventArgs args)


По предложенной ссылке зашел, но ничего не понял, что я могу в данном случае настроить

Теги:


Спасибо: Николай_Флёров


< 1 2 3 4  >
Zegen

Фотография
Дата: 09.04.2016
Ответить


Такая же ерунда. Если 14ю ставить, то ошибка как в первом посте, анблокк делал. Если 13ю ставить, то вылетает терминал.
Версия квика 7.1.2.2, винда 7.

Подскажите как победить ошибку? Кто то добрался до истины?
Спасибо: Николай_Флёров

Slepoy

Фотография
Дата: 09.04.2016
Ответить


Zegen
Такая же ерунда. Если 14ю ставить, то ошибка как в первом посте, анблокк делал. Если 13ю ставить, то вылетает терминал.
Версия квика 7.1.2.2, винда 7.Подскажите как победить ошибку? Кто то добрался до истины?


Я думаю в платной техподдержке помогут и победят ))). Денег жалко? Ну тогда парься дальше ))).
Ну вариантов решений проблемы несколько:
1. Обновить Винду до последней версии, или опробовать на чистой текущей, т.е. снести Винду, переустанвить её заного на чистый винт и опробовать;
2. Поставить последюю версию НЕТфрейворка и опробовать;
3. Согласно инструкции для ЛУА, на винду надо поставить "Visual C++ 2013 (необходимо скачать vcredist_x86.exe)".
Возможно она уже обновилась до новой версии, скажем до Visual C++ 2015. Это надо проверить и если так, то обновить;
4. Обратиться в платную техподдежку, а потом отписать тут решение для помощи другим халявщикам )))
Спасибо: Николай_Флёров

devruss

Фотография
Дата: 09.04.2016
Ответить


Сколько боли... парни, забудьте этот глючный продукт. Прошел год - создателям полностью насрать на то, что пользователи даже запустить его не могут. Им наплевать на вас - они даже отвечать не хотят.

Честно говоря, забыл данный проект как страшный сон.

Создателям: писать глючный код, который без танцев с бубном даже запустить нельзя, а потом еще и брать деньги за поддержку == помогать запускать свой же глючный код, просто аморально.

Пользователям: этот проект воспитывает терпение постоянно бороться с тоннами багов, глючным кодом и адской архитектурой - как путь к дзену, ок. Но ставить свои деньги под риск - никогда. Пользуйтесь продуктами, которые работают. Алготрейдинг и так сложен достаточно, чтобы еще усложнять себе жизнь кривыми продуктами=)
Спасибо: Николай_Флёров

Slepoy

Фотография
Дата: 10.04.2016
Ответить


Slepoy
3. Согласно инструкции для ЛУА, на винду надо поставить "Visual C++ 2013 (необходимо скачать vcredist_x86.exe)". Возможно она уже обновилась до новой версии, скажем до Visual C++ 2015. Это надо проверить и если так, то обновить;


Ахахаха. Я сделал это! Короче, действительно обновился "Visual C++ 2013" до "Visual C++ 2015". Качаем отсюда и радуемся ))).
Они видать сейчас библиотеки собирают в ВизуалСтудии 2015 и им пришлось обновить и эту штуку тоже.
В общем всё работает как положено. Короче, я походу оставил техподдержку без бабла [flapper] [lol].
Кстати, они в новом API опять выпилили пару методов, опять приходится подстраиваться.
Спасибо: Mikhail Sukhov techno1d inglerok Николай_Флёров

Mikhail Sukhov

Фотография
Дата: 10.04.2016
Ответить


devruss
Пользуйтесь продуктами, которые работают.


Сказал А, скажи и Б.
Спасибо: Николай_Флёров

Slepoy

Фотография
Дата: 10.04.2016
Ответить


devruss
Пользуйтесь продуктами, которые работают. Алготрейдинг и так сложен достаточно, чтобы еще усложнять себе жизнь кривыми продуктами=)

Это какими например?

Меня одно вымораживает в СтокШарпе, они постоянно что-то перепиливают: методы, свойства, классы. Зачем менять названия классов, интрефейсов, методов на новые - мне вообще не понятно. Вот щас обновил на новое API 4.3.14.2 и старые проект не компилируется. ЛУА скрипт заработал, но проект не компилируется. Надо обновялть НетФрейворк и переименовывать некоторые методы и свойства которые выпилили. Ну зачем они так делают? Вообще не понятно!
http://i11.pixs.ru/storage/6/1/9/Spisokoshi_2685810_21481619.jpg

Спасибо: Николай_Флёров

Slepoy

Фотография
Дата: 10.04.2016
Ответить


Slepoy
http://i11.pixs.ru/storage/6/1/9/Spisokoshi_2685810_21481619.jpg


В общем, разобрался с траблами. В новом API полностью выпилили свойство Connector из класса Order. Теперь для формирования объекта-ордера оно типа не нужно, заявки отправляются и без него. Свойство это отвечало за "Подключение к торговой системе, через который была зарегистрированна данная заявка". Кстати, в древних API оно называлось "Trader", потом переименовали в "Connector", а теперь и вовсе выпилили! Расстраивает то, что об этом выпиле - нигде нет инфы, ну по крайней мере я не нашёл. На гитхабе есть лог изменений с 4.3.13 по 4.3.14.2, в котором о данном выпиле инфы нет, или он как-то тайно заширован, ну как код Давинчи ))).

Цитата:
v4.3.14.2:
(feature) Chart. Active orders.
(bug) https://github.com/Stock...p/StockSharp/issues/222
(feature) IBTrader -> InteractiveBrokersTrader, OECTrader -> OpenECryTrader
(bug) TargetPlatformWindow fix.
v4.3.14.1:
(bug) Transaq. double <-> decimal conversation fix.
(feature) Blackwood. Embed zlib into resources.
(bug) Nuget fixed.
v4.3.14:
(feature) BaseCandleBuilderSource.RaiseProcessing perf fixes.
(feature) Ecng.Backup
(feature) Ecng.Roslyn
(feature) GuiObjectHelper removed.
(bug) Fix https://github.com/Stock...rp/StockSharp/issues/20
(feature) Chart themes.
(feature) Csv storage perf boost.
(feature) Quik lua. Tick OI.
(feature) Twime connector.
(feature) SPB exchange.
(feature) Order.Status. Nullable long.
(feature) TraderHelper. Plaza extensions.
(feature) IConnector. ConnectedEx, DisconnectedEx, ConnectionErrorEx.
(feature) Plaza. Cancel On Disconnect support.
(bug) OpenECry. Connect/disconnect fixes.
(feature) BinExporter -> StockSharpExporter.
(feature) WpfToolkit v.2.6.0.
(feature) OrderMessage.TransactionId
(bug) LogManager. Wait for disposing
(bug) TransactionBinarySerializer fix.
(bug) QuoteBinarySerializer. Fix empty depths handling.
(feature) IMessageAdapter.OrderCancelVolumeRequired
(feature) Samples. Group order cancel.
(bug) SecurityIdTextBox small fix.
(bug) RealTimeCandleBuilderSource. Raise Stopped event.
(feature) TraderHelper. IsGtc, IsToday
(feature) FIX connector. Dialects.
(feature) Transaq. v2.20.5
(feature) TimeMessage.TransactionId. String -> Long
(feature) Connector.ChangePassword
(bug) MarketDataGrid. Fix candle values.
(feature) Plaza.IsDemo
(feature) OpenECry. Uuid as SecureString.
(bug) Order.Type nullable fix.
(feature) Chart performance improved.
(feature) ExecutionMessage.BrokerCode
(feature) IStorageRegistry.GetTransactionStorage
(feature) ExecMsg. HasOrderInfo, HasTradeInfo.
(feature) ExecTypes. Order -> Transaction. Trade -> Obsolete.
(feature) ExecMsg. Volume -> OrderVolume + TradeVolume.
(bug) ProgGrid. TimeZoneInfo edit fix.
(feature) ConnectorSupportedMessagesPanel
(feature) Alerts. Removed Actipro dependency.
(bug) FIX connector. SUR currency fix.
(bug) Equity chart fix.
(feature) Message.LocalTime. DateTime -> DateTimeOffset
(bug) CandleHelper.GetCandleBounds fix.
(feature) ISecurityProvider. Performance improve.
(feature) Ecng. Strong names.
(feature) CandleSerializer. CandlePriceLevel serialization support.
(feature) StorageMessageAdapter.
(feature) Blackwood. v3.2.0
(feature) SecurityExternalId is struct.
(bug) SecurityEditor. Autocomplete fix.
(feature) ExcelExporter update.
(feature) Micex. ExtraSettings
(bug) CodeReferencesWindow. Fix loading non .NET assemblies.
(feature) ExchangeComboBox.
(feature) IConnector. Single value events.
(feature) ExecMsg. Price -> OrderPrice
(feature) ChartPanel.SecurityProvider
(feature) Plaza. OverrideDll
(feature) SecurityGrid performance improve.
(bug) OrderLog process fix.
(bug) AdvertisePanel fix.
(feature) FortsDownloader
(feature) C# 6.0 features.
(feature) Chart cluster and box.
(bug) Fix http://stocksharp.com/posts/m/33846/
(bug) FilterableSecurityProvider. Moved to Algo.
(bug) ISecurityStorage.NewSecurity event.
(bug) BasketMessageAdapter. Save/Load fix.
(feature) ConnectorWindow.
(bug) Transaq fix.
(feature) Backtesting. Use history source (Finam, Google, Yahoo) directly.



Также они сменили тип у свойства LocalTime класса Секьюрити и класса Трейд, поэтому метод ToLongTimeString - самовыпилися ))).
Раньше у свойств был тип DateTime, сейчас оно имеет тип DateTimeOffset.

Также они данное API компилировали под .NET Framework 4.5.2. А у меня стояла ВизуалСтудия 2013 с .NET Framework 4.5.1.
Для Винды пришлось качать .NET Framework 4.6.1
Для Студии пришлось качать .NET Framework 4.6.1(пакет для разработчиков)
В приниципе, уже вышла предварительная версия 4.6.2, но пока вроде сырая, хотя хрен её знает.
Кстати, при открытии публичного примера Студия заругалась и требовала именно .NET Framework 4.5.2. И это при установленном .NET Framework 4.6.1
В общем, в публичном примере у меня Студия нашла ошибки при компиляции. Тут надо или Студию обновить до 2015, или установить родной .NET Framework 4.5.2.
В общем, пока мне публичный пример не нужен, а свои проекты работают без проблем на .NET Framework 4.6.1
Ну в общем, с горем пополам, я обновил себе API.
Спасибо: Николай_Флёров

Иван З.

Фотография
Дата: 10.04.2016
Ответить


А какой смысл переходить на последнюю версию S#?
Я сейчас использую версию достаточно старую. По крайней мере исходники там на русском, сейчас смотрю на GitHab на русском ничего уже нет.
Чтоб обновлять себе API надо иметь веские основания, по моему для QUIK последний таким основанием был переход на LUA. Регулярно обновлять API S# и править свои наработки, это то еще извращение. Работа ради работы, без получения результата.

P.S.В защиту S#, посмотрите в GitHab сколько человек его делают, полноценно полтора человека. А притензий как к Microsoft.
https://github.com/Stock...harp/graphs/contributors
Спасибо: Николай_Флёров

Slepoy

Фотография
Дата: 10.04.2016
Ответить


Иван З.
А какой смысл переходить на последнюю версию S#? Я сейчас использую версию достаточно старую. По крайней мере исходники там на русском, сейчас смотрю на GitHab на русском ничего уже нет.Чтоб обновлять себе API надо иметь веские основания, по моему для QUIK последний таким основанием был переход на LUA. Регулярно обновлять API S# и править свои наработки, это то еще извращение. Работа ради работы, без получения результата. P.S.В защиту S#, посмотрите в GitHab сколько человек его делают, полноценно полтора человека. А притензий как к Microsoft. https://github.com/Stock...harp/graphs/contributors


Ну регулярно, это было бы: 4.3.13, 4.3.14, 4.3.14.1, 4.3.14.2. А я сразу с 4.3.13 на 4.3.14.2 перескочил ))). По идее, обновлять надо регулярно: это и исправление старых багов, так и новый функционал. Что сложного в том, чтобы поменять папку с Референс? Дело 2х минут. И это было бы просто, если бы разработчики использовали принцип обратной совместимости, которого, к сожалению, - нет. Надо выпиливать методы/классы на глобальных изменениях, ну скажем на версии 5.0.0, или 6.0.0, а в промежуточных релизах использовать обратную совместимость, ну т.е. не нужно было выпиливать свойство Connector, нужно было его просто нейтрализовать, чтобы оно просто бездействовало. Пусть висит себе в коде просто так, до выхода глобально-новой версии 5.0.0. И тогда проблем бы не было никаких. Но даже это не главное, а то что нет информации по внесённым измененииям. Если бы я знал, что будет такие траблы: с ЛУА, с NET, со свойсвами, я возможно бы, обновился на пару промежуточных версий позже. Ну даже если бибилотеки и пилят 1.5 человека, что сложного в том, чтобы написать 2-3 строчки об изменениях? Да им самим потом будет легче ориентироваться в этом.


Спасибо: Николай_Флёров

Mikhail Sukhov

Фотография
Дата: 10.04.2016
Ответить


Иван З.
А какой смысл переходить на последнюю версию S#?


Обновляются не только наши библиотеки, но и брокерские платформы. В принципе, можно не обновляться, но нужно быть готовым заложить код от сбоев, которые может выбросить в рынок приличную часть от счета.

Иван З.

посмотрите в GitHab сколько человек его делают, полноценно полтора человека.


Это не так. Я чаще всего мержду коммиты от других людей (которые не имеют доступ к репозитарию).

Иван З.

А притензий как к Microsoft.


А какие именно претензии? Я может что-то пропустил? Готов рассмотреть.
Спасибо: Николай_Флёров
< 1 2 3 4  >

Добавить файлы через драг-н-дроп, , или вставить из буфера обмена.

loading
clippy